11.0 Beta -> MIDI control via DAW -> KPA receiving Midi on all channels

  • The Profiler Model referred to in this thread is ...
    ☑️ Profiler Head/Rack

    Hi,

    since the update to 11.0 Beta, MIDI control of the KPA via DAW no longer works properly. For example, if the Kemper is set to MIDI channel 2 and you set the DAW-MIDI track with PCs and CCs to any other channel, the Kemper nonetheless switches.

  • A little disrespectful to be honest 😉


    The OP has been a member since 2015 so probably know soon their way around the Kemper by now.

    The clip above posted by jock is actually an extract of the "what's new in 11.0" - so quoting it should probably not be seen as disrespect, rather a friendly hint that there is information on things that have CHANGED that can be found in the "11.0 addendum" document in the manual downloads section. This one around MIDI channel is pretty relevant, since it is actually a "breaking change", i.e. it makes your Kemper behave differently from before.

    "Knowing your way around the Kemper" doesn't really help when things get changed by Kemper - that actually causes things "not to work anymore".

    To address the OP's issue: the 11 beta update causes any settings you have made to the MIDI receive channel to get lost and reset to "omni". To fix this, you simply need to re-make that setting in System Settings-->Global MIDI channel; change it from "omni" to your required MIDI channel.

    Love & peace,

    Torsten

    • Official Post

    Just some background. When we added the MIDI Global Channel setting for the Player model we had to move this parameter internally. That's why it needs to be re-entered at non-Player models. If it was anyhow left at its default setting "Omni" no action is needed. Normally we try to avoid such disruptive changes, sorry!

    The changelog also includes a related note by the way.

  • The clip above posted by jock is actually an extract of the "what's new in 11.0" - so quoting it should probably not be seen as disrespect, rather a friendly hint that there is information on things that have CHANGED that can be found in the "11.0 addendum" document in the manual downloads section. This one around MIDI channel is pretty relevant, since it is actually a "breaking change", i.e. it makes your Kemper behave differently from before.

    "Knowing your way around the Kemper" doesn't really help when things get changed by Kemper - that actually causes things "not to work anymore".

    To address the OP's issue: the 11 beta update causes any settings you have made to the MIDI receive channel to get lost and reset to "omni". To fix this, you simply need to re-make that setting in System Settings-->Global MIDI channel; change it from "omni" to your required MIDI channel.

    Love & peace,

    Torsten

    I always read RTFM as attempt to say "Hey, dumba$$".

    I think most people find an answer of "RTFM" as rude. The wink emojii at the end makes the writer feel better, but does nothing for the reader. ;)

  • I think most people find an answer of "RTFM" as rude.

    To me it depends on what else is in the post - since jock actually posted some helpful information and not just "RTFM", I personally wouldn't interpret that post as rude - there is also a friendly interpretation "read the fine manual", after all.

    But that's just me, generally assuming people are well-intended - until they disappoint me too much...

  • I'm not getting into another "I am right and you are wrong" type of debate...

    Just asking the question: who actually provided some helpful information to the OP?

    Hint: it wasn't any of the "this post is rude" commenters...

  • I'm not getting into another "I am right and you are wrong" type of debate...

    Just asking the question: who actually provided some helpful information to the OP?

    Hint: it wasn't any of the "this post is rude" commenters...

    Wasn’t my intention to sound antagonistic.

    I should be more careful with my writing.

    "Without music, life would be a mistake.” ― Friedrich Nietzsche


    Contact - Kemper Amps

    Edited once, last by Ruefus (May 20, 2024 at 1:12 AM).

  • I'm not getting into another "I am right and you are wrong" type of debate...

    Just asking the question: who actually provided some helpful information to the OP?

    Hint: it wasn't any of the "this post is rude" commenters...

    Torsten, you are correct. I misinterpreted the original post and jock ‘s reply. The RTFM part of the response was a bit “rude” for want pf a better phrase but my response was equally unnecessary. Let’s all put it to bed now. As Burkhard has confirmed there was a change (which I hadn’t spotted) that required the OP to tweak his settings so hopefully the issue is resolved.